Hysteroscopy - polyps found

Discussion group for people not currently undergoing treatment.

Moderator: Administrator

Post Reply
Message
Author
Kelly1981
Posts: 98
Joined: Thu Aug 17, 2017 2:22 pm

Hysteroscopy - polyps found

#1 Post by Kelly1981 » Tue Oct 17, 2017 5:12 pm

Hi All

So I've had 1 failed lVF with one frozen blastocyst waiting for us.

My consultant sent me for a hysteroscopy just incass before we have our FETV & they found & removed polyps.

Has anyone else had the same & had more success?

Thanks in advance for any feedback

CharB
Posts: 583
Joined: Tue Jan 23, 2018 10:37 am

Re: Hysteroscopy - polyps found

#2 Post by CharB » Mon May 06, 2019 8:46 am

Hi Kelly,

Our first FET was supposed to be on Tuesday, but after over an hour and a half in theatre and 2 drs trying, the catheter would not go into my uterus.

It was a very traumatic morning. I now need a Hysteroscopy to find out whats blocking me and remove it. I had major abdominal surgery almost 15 years ago so i suspect it could be scar tissue. However i have a rare genetic condition which causes polyps to grow in the large intestine, hence my major surgery. So i am wondering if its polyps.

Very frustrating! How long did you have to wait for the Hysteroscopy?

Kind regards

Charlotte
Cycle 1 - EC - 6 eggs. 5 fertilised - 1 blastocyst
Cycle 2 - EC - 13 eggs, 7 fertilised - 2 blastocysts
Cycle 3 - FET - unable to transfer :(
Cycle 4 - FET - BFP 08/10/19 :D

CharB
Posts: 583
Joined: Tue Jan 23, 2018 10:37 am

Re: Hysteroscopy - polyps found

#3 Post by CharB » Mon May 06, 2019 8:47 am

Just realised how long ago you posted :lol:
Cycle 1 - EC - 6 eggs. 5 fertilised - 1 blastocyst
Cycle 2 - EC - 13 eggs, 7 fertilised - 2 blastocysts
Cycle 3 - FET - unable to transfer :(
Cycle 4 - FET - BFP 08/10/19 :D

Post Reply